:+: Say to U :+:

구글은 12월 19알 안드로이드 앱들의 안정성 및 성능 향상을 목적으로 내년초부터 안드로이드 생태계 전체에 있을 변화를 Android Developers Blog를 통해 공개하였습니다.




구글이 밝힌 내용은 첫번째로 2018년 하반기 출시되거나 업데이트 되는 앱은 출시 당시 최신 API를 지원해야하며, 이를 위해 2018년 8월이후 신규 출시앱 및 2018년 11월 이후 업데이트앱은 최소한 API 레벨 26이상을 지원할 것을 권고하였습니다.


또한, 2019년 8월 이후에 출시되거나 업데이트되는 앱은 32비트가 아닌 64비트 코드로 제작되어야 하는 것입니다. 그동안 구글은 2015년 출시된 안드로이드 5.0 롤리팝부터 64비트 앱을 지원하였지만, 애플처럼 강제적인 조치를 통한 전환을 하지는 않았으나 향후 출시되는 앱은 64비트를 필수로 지원해야하므로 메모리 사용 및 억세스 속도등에서 상당한 이점이 있을 예정입니다.


그리고, 2018년 초부터는 APK 파일에 보안 대첵에 대한 메타 테이터가 필수로 포함되어야 하며, 이는 개발자가 사전에 작업을 해야하는 것은 아니지만 프로그램 검증용으로 사용되어 앱의 보안성등에 많은 도움을 줄 것으로 보입니다.



출처 : Android Developers Blog外


Comment +0